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[bookmark: _Toc31887729]Introduction
The Participant Validation Tool (PVT) is a Microsoft® Excel Add-in application designed to assist users of VETS’ Technical Performance Report (TPR) workbook template by verifying template integrity and providing validation feedback for participant records.[footnoteRef:1] Due to the inherent flexibility of the Excel environment, workbook templates can sometimes become inadvertently compromised, negatively affecting their ability to accurately capture and present performance data. The PVT aims to assist by detecting such issues, and providing the opportunity for an uncompromised template to be used. [1:  Future versions of the Add-in may include additional functionality] 


Quality individual participant records are at the heart of accurate grant performance measurement. Therefore, the primary goal of the PVT is to check each participant record against applicable VETS grant program business rules and append validation feedback directly to problematic records. Flagged cells are highlighted and appended with comments containing error messages or other information necessary to resolve issues or improve quality. A validation summary report is also generated, showing error counts by sheet (participant records may span multiple worksheets) and error type.
[bookmark: _Toc31887730]Compatibility / Prerequisites
[bookmark: _Toc31887731]Compatibility
The PVT Excel Add-in application is backward-compatible to version 2010 of Microsoft® Excel, with Microsoft Windows 7 or later.
[bookmark: _Toc31887732]Prerequisites
The PVT Add-in application requires a compatible version of the TPR for correct operation. The version of the TPR you’re using should be shown on several of the sheets within the workbook (appearance and location may vary depending on the version). For example, within the 
PY2018 1.1 version of the TPR, look for the version information within the starburst graphic at the top of either the Goals, TPR, Demographic, or quarterly Exiter Info sheets (Figure 1).

[bookmark: _Ref5701596]Figure 1 - Starburst graphic showing TPR workbook version number


NOTE: Legacy versions of the TPR workbook are not compatible with the PVT.

Older versions (those before PY2018, version 1.1) of the TPR workbook will not be recognized as valid by the PVT, and will be bypassed during its validation process. Any incompatible / bypassed workbook files processed by the PVT will show, “<No Match>”, on the validation report generated at the end of a validation pass. Therefore, please make sure you’re using a compatible version of the TPR to get the full benefit of the PVT.
[bookmark: _Toc31887733]Download & Installation
[bookmark: _Toc31887734]Download
The latest version of the PVT is available on the HVRP website (https://www.dol.gov/agencies/vets/programs/hvrp), in the same location where TPRs and supplemental documents are posted (Figure 2): 

[bookmark: _Ref5806839]Figure 2- dol.gov download location of TPR and PVT application files (actual view may vary)


The PVT application is provided in a compressed file with a .ZIP extension. Double-click the downloaded .ZIP file, and choose a location on your local system where to unpack the contents.
[bookmark: _Toc31887735]Installation
[bookmark: _Toc31887736]Digital Signatures
A digital signature is means of assuring electronic documents are authentic as having come from the signer, and not been altered.  For more information on digital signatures, please see this support content from Microsoft, or search the topic using your preferred provider. 

The PVT application is digitally signed by VETS, and depending on the Trust Center settings within MS Excel, you may see the following upon opening it:

Figure 3 - Trust Center Digital Signature Notification.


Please make sure the PVT application file you’re installing has a valid digital signature (e.g. has not been altered since last signed by DOL). If the digital signature shows as invalid, please obtain a new copy of the PVT from the HVRP website (https://www.dol.gov/agencies/vets/programs/hvrp), and/or contact your GOTR for assistance. Otherwise, click “Enable Macros” at the prompt.
[bookmark: _Toc31887737][bookmark: _Ref5968673][bookmark: _Ref5969047][bookmark: _Ref5969060]Setting up Excel
 VBA & ActiveX
The PVT requires the enablement of both VBA macros and ActiveX controls within your MS Excel Trust Center settings:

1. Go to the File tab and click Options=>Trust Center, then click the Trust Center Settings button.
2. To configure ActiveX Settings, click “ActiveX Settings” on the left and tick, “Prompt me before enabling all controls with minimal restrictions”. Safe mode may also be ticked (Figure 4). If ActiveX is not enabled, you may receive a compile error when attempting to run the TPR or PVT (Figure 5).

[bookmark: _Ref5801116]Figure 4 - Trust Center Settings for ActiveX Controls.


[bookmark: _Ref5801133]Figure 5 - Compile Error if ActiveX Controls Are Disabled..


3. To configure Macro Settings, click “Macro Settings” on the left and tick, “Disable all macros with notification”. Leave “Trust access to the VBA project object model” unchecked (Figure 6).

Excel is now configured to present notifications when Macros or ActiveX controls are invoked. When shown, click the “Enable Content” button when prompted by any yellow-banded notifications appearing under the ribbon at the top of the Excel window when the TPR or PVT are opened (Figure 7):[bookmark: _Ref5801800]Figure 6 - Trust Center Settings for Macros.
[bookmark: _Ref5801657]Figure 7 - Click Enable Content within the security prompt.


4. In general, if the Participant Validator control under the DOL-VETS ribbon tab group seems to do nothing when clicked, it is an indicator that macros, ActiveX, or other Trust Center settings are inhibiting the application from running properly.

Figure 8 - DOL-VETS Add-in ribbon control tab

 Protected View
Protected View can prevent active content from running in Excel documents, particularly those obtained from internet or network locations. If your copy of the PVT appears to be missing elements such as the DOL-VETS tab and/or other controls, you may need to disable Protected View for the affected document:

1. Go to File => Options => Trust Center and click the Trust Center Options button.
2. Select Protected View in the column on the left and try unchecking some of the options listed.

[image: ]
Figure 9 - Protected View Settings in Trust Center

[bookmark: _Toc31887738]Install as Add-in
When installed as an Add-in, the PVT will run every time Excel is opened and be available as a ribbon control at the top of the Excel interface in the DOL-VETS tab.

Method 1 – User-Defined Startup

1. Create a folder to house the PVT Add-in file on your local machine in a location of your choosing, preferably where it is unlikely to be inadvertently moved, altered, or deleted (network locations are not recommended).
2. Copy the PVT add-in file (.xlam) and only that file to the folder, noting the path to its location (e.g., c:\users\john\documents\hvrp).
3. Open Excel and go to File=>Options=>Advanced and scroll down to the ‘General’ section. 
4. Type or cut/paste the path of the folder into the “At startup, open all files in:” box (Figure 9 ).

[bookmark: _Ref10616326][bookmark: _Ref10616315]Figure 10 - Configuring Excel to open the PVT from a user-defined folder

5. Save and restart Excel.

Method 2 – Office Integration

NOTE: Local configuration policy of your Office/Windows environment could inhibit the retention of the configuration settings provided below.  If that is the case, please try the User-Defined Startup method of installing the PVT Add-in.

1. To install as an Add-in, copy the PVT (.xlam) file to the designated Office Add-in folder on your Windows® system substituting your system username in the path (you may need to unhide the folder in File Explorer to see it):

Figure 11 - Show Hidden Files/Folders in File Explorer


Location: C:\Users\<your user name>\AppData\Roaming\Microsoft\AddIns

2. To enable the PVT, go to File=>Options=>Add-ins
3. Make sure Excel Add-ins is selected in the “Manage” dropdown, and click the, “Go…”, button.
Figure 12 - Add-in manager


4. Tick the box next to the PVT’s .xlam filename in the installed Add-ins list:

Figure 13 - Select the PVT (name may vary) in the list and hit 'OK'.


5. To remove the PVT, perform the previous instructions in reverse.

[bookmark: _Toc31887739]Run in Standalone Mode
Optionally, you can run the .xlam file directly by simply double-clicking it. Excel will open with the DOL-VETS ribbon tab available, but without a default worksheet.
[bookmark: _Toc31887740]Performing Participant Validation
[bookmark: _Toc31887741]Submitting TPR Templates for Validation

1. Click the Participant Validator button in the DOL-VETS ribbon tab.
2. In the file browser window that appears, select TPR file(s) you wish to validate (hold CTRL while left-clicking to select multiple files) (non-Excel files are filtered from the browser view by default). 
3. With the desired files selected, click the “Open” button.
4. If you’ve selected TPR file(s) that are already open in Excel, you’ll be prompted for each to be allowed to close and reopen. Reopened files will be processed, but may lose unsaved changes made before the validation run. Files not reopened will be skipped during the validation run.  
Additionally, target TPR files must be in a writeable state / location.  If not, you may receive errors or the validation feedback may not be written as expected (e.g. MS SharePoint). Move the target TPR files to a location to which they can be written (such as your local machine).
5. A window will appear showing the progress of the validation pass.
6. Click the “Cancel” button, or the close the progress window (“X”) to cancel the validation pass. You may need to click a few times, since the application must complete the current file before executing the cancellation.
7. When the validation pass is complete, the report will be opened in a new workbook file (Figure 12):

[bookmark: _Ref5804387]Figure 14 - Participant Validation Report


8. If a submitted template was not compatible with the PVT or fails its integrity test, “<No Match>” will be shown in the report’s result detail for that template. The performance data should be moved to a new and/or compatible template.
9. If a submitted template was compatible and passed the PVT’s integrity test, its version number will be shown on the report’s result detail, along with error counts by sheet and error type.
10. Passing templates will have participant validation error feedback written directly to them in the affected areas.
11. Flagged cells on any of the Participant/Exiter Qx sheets will be colored red, and have a comment describing the error(s)(Figure 13):

[bookmark: _Ref5805820]Figure 15 - Errors Highlighted with Comments appended.


12. Errors are categorized into types representing the degree of severity: Error, Warning, and Information. The types are differentiated by color-coded tags within the cell’s comment.
13. Generally speaking, Error-type flags should be resolved using the information provided in the validation comment(s).
14. The less-severe Warning and Information flags may be items that should be monitored or reviewed, or may simply be reminders or other information.
[bookmark: _Toc31887742]Clearing Previously-Flagged Errors
To clear/update the validation feedback within a TPR template after making changes, you must re-run the file through the PVT.

[bookmark: _Toc31887743]Troubleshooting
[bookmark: _Toc31887744]Participant Validator Button Does Nothing
· You must configure Excel’s Trust Center to allow Macros and ActiveX (see III.2.2)
[bookmark: _Toc31887745]Made Corrections But Cells Still Show Errors
· Save and close the file, then rerun it through the PVT.
[bookmark: _Toc31887746]Getting Compiler Error
· Likely due to ActiveX controls not being enabled (see III.2.2). Otherwise, try downloading and using a new copy of the PVT and or TPR.  If still unsuccessful, please contact your GOTR or email contact(s) listed in this document (see Contact).
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